Discussion:
Nominatim install fails (DB Error: extension not found)
(too old to reply)
Helenius Klaus
2013-10-01 14:13:42 UTC
Permalink
Raw Message
I get the following error message when I try to run
'./utils/setup.php --osm-file <your planet file> --all'

http://pastebin.com/7bg2Mj5t

What causes this and how could I fix it?

I'm running Arch Linux on this machine and am quite sure that I installed
all the requirements.

-Klaus
Sarah Hoffmann
2013-10-01 14:42:40 UTC
Permalink
Raw Message
Hi,
Post by Helenius Klaus
I get the following error message when I try to run
'./utils/setup.php --osm-file <your planet file> --all'
http://pastebin.com/7bg2Mj5t
What causes this and how could I fix it?
I'm running Arch Linux on this machine and am quite sure that I
installed all the requirements.
The DB pear module is looking for the extension that allows it to
connect to postgresql databases. Try finding a package called php-pgsql
or similar

Sarah
Helenius Klaus
2013-10-01 14:48:21 UTC
Permalink
Raw Message
Hi,

I've installed php-pgsql so it shouldn't be the culprit.

-Klaus
Post by Sarah Hoffmann
Hi,
Post by Helenius Klaus
I get the following error message when I try to run
'./utils/setup.php --osm-file <your planet file> --all'
http://pastebin.com/7bg2Mj5t
What causes this and how could I fix it?
I'm running Arch Linux on this machine and am quite sure that I
installed all the requirements.
The DB pear module is looking for the extension that allows it to
connect to postgresql databases. Try finding a package called php-pgsql
or similar
Sarah
Brian Quinion
2013-10-01 15:18:51 UTC
Permalink
Raw Message
Post by Helenius Klaus
I've installed php-pgsql so it shouldn't be the culprit.
That error would definitely related to the php-pgsql module being missing.

Possibly it didn't install correctly or was only installed the apache
version of php?

--
Brian
Shaun McDonald
2013-10-01 15:22:00 UTC
Permalink
Raw Message
Post by Brian Quinion
Post by Helenius Klaus
I've installed php-pgsql so it shouldn't be the culprit.
That error would definitely related to the php-pgsql module being missing.
Possibly it didn't install correctly or was only installed the apache
version of php?
Another option is that it was installed but the plugin wasn't enabled in the Apache config?

Shaun
Helenius Klaus
2013-10-01 17:36:15 UTC
Permalink
Raw Message
I've yet to install any web server (apache, lighttpd or such) since I
thought I wouldn't need one yet for database import step.

-Klaus
Post by Shaun McDonald
Post by Brian Quinion
Post by Helenius Klaus
I've installed php-pgsql so it shouldn't be the culprit.
That error would definitely related to the php-pgsql module being missing.
Possibly it didn't install correctly or was only installed the apache
version of php?
Another option is that it was installed but the plugin wasn't enabled in the Apache config?
Shaun
_______________________________________________
Geocoding mailing list
Geocoding at openstreetmap.org
https://lists.openstreetmap.org/listinfo/geocoding
Helenius Klaus
2013-10-03 11:33:13 UTC
Permalink
Raw Message
Ok, I needed to uncomment 'extension=pgsql.so' from php.ini and got a
little further.

But now I seem to have too new version of postgresql:
"ERROR: PostgreSQL version is not correct. Expected 9.1 found 9.2"

Can I use 9.2 version by editing setup without problems or do I need to
downgrade?

-Klaus
Post by Brian Quinion
Post by Helenius Klaus
I've installed php-pgsql so it shouldn't be the culprit.
That error would definitely related to the php-pgsql module being missing.
Possibly it didn't install correctly or was only installed the apache
version of php?
--
Brian
Sarah Hoffmann
2013-10-03 12:02:03 UTC
Permalink
Raw Message
Post by Helenius Klaus
Ok, I needed to uncomment 'extension=pgsql.so' from php.ini and got
a little further.
"ERROR: PostgreSQL version is not correct. Expected 9.1 found 9.2"
Can I use 9.2 version by editing setup without problems or do I need
to downgrade?
Edit your settings/local.php and supply the correct versions.
There is an example in the installation instructions. The only
requirement is that postgres has to be >= 9.0.

Sarah
Post by Helenius Klaus
Post by Brian Quinion
Post by Helenius Klaus
I've installed php-pgsql so it shouldn't be the culprit.
That error would definitely related to the php-pgsql module being missing.
Possibly it didn't install correctly or was only installed the apache
version of php?
--
Brian
Sarah Hoffmann
2013-10-01 15:23:15 UTC
Permalink
Raw Message
Post by Helenius Klaus
I've installed php-pgsql so it shouldn't be the culprit.
I've occasionally had trouble with pear DB itself. Removing it
and installing again helped in these cases.

Sarah
Post by Helenius Klaus
Post by Sarah Hoffmann
Hi,
Post by Helenius Klaus
I get the following error message when I try to run
'./utils/setup.php --osm-file <your planet file> --all'
http://pastebin.com/7bg2Mj5t
What causes this and how could I fix it?
I'm running Arch Linux on this machine and am quite sure that I
installed all the requirements.
The DB pear module is looking for the extension that allows it to
connect to postgresql databases. Try finding a package called php-pgsql
or similar
Sarah
Helenius Klaus
2013-10-03 08:33:30 UTC
Permalink
Raw Message
I've now tried to reinstall php-pgsql and pear DB and I still get same
errors :/

-Klaus
Post by Sarah Hoffmann
Post by Helenius Klaus
I've installed php-pgsql so it shouldn't be the culprit.
I've occasionally had trouble with pear DB itself. Removing it
and installing again helped in these cases.
Sarah
Post by Helenius Klaus
Post by Sarah Hoffmann
Hi,
Post by Helenius Klaus
I get the following error message when I try to run
'./utils/setup.php --osm-file <your planet file> --all'
http://pastebin.com/7bg2Mj5t
What causes this and how could I fix it?
I'm running Arch Linux on this machine and am quite sure that I
installed all the requirements.
The DB pear module is looking for the extension that allows it to
connect to postgresql databases. Try finding a package called php-pgsql
or similar
Sarah
Loading...